Exchange+Outlook:Exchange 2010 Dienste starten nicht

Aus Znilwiki
Wechseln zu: Navigation, Suche

Fehlerbeschreibung

Exchange 2010 (oder auch Exchange 2007) startet nach einem Neustart des Servers nicht mehr richtig?
Braucht ewig zum booten? Die Dialoge / Systemverwaltung etc. lassen sich nicht richtig öffnen?

  • Sie haben eines der folgenden Sachen gemacht?
    • Das Netzwerkprotokoll IPv6 deaktiviert
    • Von Exchange 2003 auf 2010 / 2007 migriert und den alten Exchange Server deinstalliert
    • Einen der Domänencontroller deinstalliert (dcpromo.exe Rückwärts)
    • Highlight wäre wenn der alte Exchange auch gleichzeitig Domänencontroller war



Ereignisanzeige


System

In der Ereignisanzeige haben Sie eine der folgenden Fehlermeldungen / Event ID / Ereignis-ID

Protokollname: System
Quelle:        Service Control Manager
Datum:         20.06.2011 23:34:03
Ereignis-ID:   7031
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Der Dienst "Microsoft Exchange-Informationsspeicher" wurde unerwartet beendet. Dies ist bereits 1 Mal vorgekommen.
Folgende Korrekturmaßnahmen werden in 5000 Millisekunden durchgeführt: Neustart des Diensts.
Protokollname: System
Quelle:        Service Control Manager
Datum:         20.06.2011 23:34:03
Ereignis-ID:   7024
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Der Dienst "Microsoft Exchange-Informationsspeicher" wurde mit folgendem dienstspezifischem Fehler beendet: %%2415.
Protokollname: System
Quelle:        Service Control Manager
Datum:         20.06.2011 23:08:17
Ereignis-ID:   7000
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Der Dienst "Geschützter Microsoft Exchange-Diensthost" wurde aufgrund folgenden Fehlers nicht gestartet: 
Der Dienst antwortete nicht rechtzeitig auf die Start- oder Steuerungsanforderung.
Protokollname: System
Quelle:        Service Control Manager
Datum:         20.06.2011 23:08:17
Ereignis-ID:   7009
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Das Zeitlimit (30000 ms) wurde beim Verbindungsversuch mit dem Dienst Geschützter Microsoft Exchange-Diensthost erreicht.
Protokollname: System
Quelle:        NETLOGON
Datum:         20.06.2011 11:13:21
Ereignis-ID:   5719
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Der Computer konnte eine sichere Sitzung mit einem Domänencontroller in der Domäne CO-LO-TRANS aufgrund der folgenden Ursache nicht einrichten: 
Es sind momentan keine Anmeldeserver zum Verarbeiten der Anmeldeanforderung verfügbar. 
Dies kann zu Authentifizierungsproblemen führen. Stellen Sie sicher, dass der Computer mit dem Netzwerk verbunden ist.
Wenden Sie sich an den Domänenadministrator, wenn das Problem weiterhin besteht.  

ZUSÄTZLICHE INFORMATIONEN 
Wenn dieser Computer ein Domänencontroller der bestimmten Domäne ist, wird eine sichere Sitzung zum primären 
Domänencontrolleremulator in der bestimmten Domäne eingerichtet. Andernfalls richtet dieser Computer 
eine sichere Sitzung zu einem beliebigen Domänencontroller in der bestimmten Domäne ein.
Protokollname: System
Quelle:        Service Control Manager
Datum:         20.06.2011 12:41:16
Ereignis-ID:   7022
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Der Dienst "Microsoft Exchange Active Directory-Topologie" wurde nicht richtig gestartet.
Protokollname: System
Quelle:        Service Control Manager
Datum:         20.06.2011 12:41:16
Ereignis-ID:   7022
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Der Dienst "Microsoft Exchange Active Directory-Topologie" wurde nicht richtig gestartet.
Protokollname: System
Quelle:        Service Control Manager
Datum:         20.06.2011 12:21:56
Ereignis-ID:   7001
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Der Dienst "Microsoft Exchange-Adressbuch" ist vom Dienst "Microsoft Exchange Active Directory-Topologie" abhängig, der aufgrund folgenden Fehlers nicht gestartet wurde: 
Der Dienst konnte nicht gestartet werden.

Anwendungen

Protokollname: Application
Quelle:        MSExchange ADAccess
Datum:         20.06.2011 23:22:51
Ereignis-ID:   2114
Aufgabenkategorie:Topologie
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Prozess MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=4132). Fehler bei der Topologieerkennung. Fehler: 0x80040a02 (DSC_E_NO_SUITABLE_CDC).  
Protokollname: Application
Quelle:        MSExchange ADAccess
Datum:         20.06.2011 23:25:24
Ereignis-ID:   2501
Aufgabenkategorie:Allgemein
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Prozess MSEXCHANGEADTOPOLOGY (PID=3184). Fehler beim Überprüfen des aktuellen Standortnamens durch den Standortmonitor - Anruf=HrSearch Fehlercode=80040a01.  
Protokollname: Application
Quelle:        MSExchange ADAccess
Datum:         20.06.2011 23:25:24
Ereignis-ID:   2601
Aufgabenkategorie:Allgemein
Ebene:         Warnung
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Prozess MSEXCHANGEADTOPOLOGY (PID=3184). Fehler beim Abrufen der SID für Konto 
'<WKGUID=1A9E39D35xxxxxxxx979FFC0C6E5EA26,CN=Microsoft  Exchange,CN=Services,CN=Configuration,...>' 
durch Exchange während des Initialisierens eines RPCs (Remote Procedure Call)
an den Microsoft Exchange Active Directory-Topologiedienst - Fehlercode=80040a01. 
Der Microsoft Exchange Active Directory-Topologiedienst wird weiterhin mit eingeschränkten Berechtigungen gestartet.
Protokollname: Application
Quelle:        MSExchange ADAccess
Datum:         20.06.2011 23:25:20
Ereignis-ID:   2080
Aufgabenkategorie:Topologie
Ebene:         Informationen
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xxx
Beschreibung:
Prozess STORE.EXE (PID=3384). Der Exchange Active Directory-Anbieter hat folgende Server mit folgenden Eigenschaften gefunden: 
(Servername | Rollen | Aktiviert | Erreichbarkeit | Synchronisiert | GK-fähig | PDC | SACL-Recht | Benötigte Daten | Netlogon | Betriebssystemversion) 
Innerhalb des Standorts:
DC01.xxx.xx	CDG 1 7 7 1 0 0 1 7 1
Außerhalb des Standorts:
Protokollname: Application
Quelle:        MSExchangeIS
Datum:         20.06.2011 23:25:15
Ereignis-ID:   1121
Aufgabenkategorie:Allgemein
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Fehler '0x96f' beim Verbinden mit Active Directory.

Weg zur Rettung

Die Fehlermeldungen oben stammen alle vom selben Server / Kunden. Dort gab es einen vorhandenen Windows Server 2003 Domänencontroller der gleichzeitig auch Exchange 2003 Server war. Dieser wurde durch einen Windows Server 2008 R2 Server als Domänencontroller und einen zweiten 2008 R2 Server als Exchange 2010 Server abgelöst.
Die Probleme fingen an nach der Deinstallation des alten Exchange Servers und der Deinstallation des Domänencontrollers auf dem alten Server.
Die Postfächer und Öffentlichen Ordner waren selbstverständlich vorher alle Verschoben worden, alle Rollen für Exchange (z.B. Adressbuch) und Active Directory wurden zuvor ordnungsgemäß an die neuen Server übergeben.
Trotzdem ging erst einmal gar nichts. Bei mir kamen viele Gründe auf einmal zusammen - am Ende kommt die Zusammenfassung.
Wenn Ihr vor dem selben Problem steht - nachfolgend meine Liste zum abarbeiten:

  • Der Exchange Server sollte einen Weg ins Internet kennen - der will unter anderem Zertifikate etc. abfragen. Also ggf. auf der Firewall freischalten
  • Startet den Exchange Server einmal neu im abgesicherten Modus (F8 beim Start drücken, unmittelbar nach BIOS Meldung)
  • Anmelden, Verwaltung der Diensts aufrufen (Start -> Ausführen -> services.msc)
  • Bearbeitet alle Dienste die mit "Microsoft Exchange ..." anfangen
    • alle Dienste die auf "Automatisch stehen" setzt Ihr auf Manuell
    • alle Dienste die auf "Manuell" stehen setzt Ihr auf "Deaktiviert"
    • Der Dienst "Microsoft Exchange Active Directory-Topologie" wird später trotzdem starten - nicht schlimm, mit dem suchen wir den Fehler
  • Prüft die Einstellungen der Netzwerkkarte:
    • Richtiger DNS-Server? Sollte auf den neuen DNS-Server zeigen (Der in der Regel auch der Domänencontroller ist)
    • Das IPv6-Protokoll MUSS unbedingt aktiviert sein auf der Netzwerkkarten-Schnittstelle !!!!!
  • Exchange Server normal neu starten
  • Auf den Domänencontroller Wechseln - wir kümmern uns um das "Ereignis-ID: 2080" Problem was uns weitere wertvolle Hinweise gegeben hat
    • "CDG 1 7 7 1 0 0 1 7 1" zeigt uns das er Probleme hat, mindestens ein Server muss "CDG 1 7 7 1 0 1 1 7 1" haben
  • Active Directory-Benutzer und -Computer öffnen
    • Rechte Maustaste auf den Domänennamen und "Suchen..." auswählen
    • Suchbegriff: Exchange -> Er zeigt uns alle Exchange Gruppen an
    • In die Gruppen
      • Exchange Servers
      • Exchange Enterprise Servers
      • Exchange Domain Servers
    • gehen und prüfen ob dort der Exchange 2010 / 2007 Server Mitglied ist - wenn nicht nachtragen (Auch wenn er über andere Gruppe schon Mitglied wäre)
      • Doppelklick auf Gruppenname
      • Karteireiter "Mitglieder"
      • Hinzufügen
      • Oben Rechts die "Objekttypen" anklicken und zusätzlichen Haken bei "Computer" setzen
      • Im Textfeld unten nun den Namen des Exchangeservers eingeben (z.B. EX01) und auf "Namen überprüfen" klicken -> Der Name sollte unterstrichen werden
      • nun unten auf "OK" klicken
    • Das ganze für alle obigen Gruppen wiederholen
  • Gruppenrichtlinienverwaltung öffnen (In der Verwaltung)
    • Wenn es die nocht nicht gibt -> Servermanager -> Features -> Features hinzufügen -> Gruppenrichtlinienverwaltung (Schön das bei 2008 keine DVD mehr gebraucht wird bei so etwas)
    • Zu "Gruppenrichtlinenverwaltung" -> "Gesamtstruktur" -> "Domänen" -> "Domänenname" -> "Gruppenrichtlinienobjekte" navigieren
    • Rechtsklick auf "Default Domain Controllers Policy" und "Bearbeiten" auswählen
      • Navigieren zu
      • Computerkonfiguration -> Richtlinien -> Windows-Einstellungen -> Sicherheitseinstellungen -> Lokale Richtlinien -> Zuweisen von Benutzerechten
      • Die Richtlinie "Verwalten von Überwachungs- und Sicherheitsprotokollen" bearbeiten
        • Die Gruppe "Administratoren" hinzufügen
        • Die Gruppe "Exchange Enterprise Servers" hinzufügen
        • Die Gruppe "Exchange Servers" hinzufügen
      • Gruppenrichtlinie schliessen
      • Noch einmal prüfen ob wir auch wirklich die "Default Domain Controllers Policy" und NICHT die "Default Domain Policy" geändert haben - in diesem Fall Rückgängig machen und noch mal von vorn
      • Gruppenrichtlinienverwaltung schliessen
    • Auf dem Domänencontroller die Gruppenrichtlinien aktualisieren
      • Start -> Ausführen -> gpupdate /force
      • ggf. erst DOS-Box öffnen und dort ausführen um Fehlermeldungen lesen zu können (Start -> Ausführen -> cmd --- und dann erst gpupdate /force
  • Zurück zum Exchange Server wechseln
    • Auch hier einmal die Gruppenrichtlinien aktualsieren (Start -> Ausführen -> gpupdate /force)
    • Den Dienst "Microsoft Exchange Active Directory-Topologie" starten
    • Ins Ereignisprotokoll - Anwendungen schauen dort sollten folgende Meldungen auftauchen:
Protokollname: Application
Quelle:        MSExchange ADAccess
Datum:         20.06.2011 23:34:36
Ereignis-ID:   2800
Aufgabenkategorie:Allgemein
Ebene:         Informationen
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.xxx.xx
Beschreibung:
Prozess MSEXCHANGEADTOPOLOGY (PID=4832). Der Microsoft Exchange Active Directory-Topologiedienst wurde erfolgreich gestartet.

und

Protokollname: Application
Quelle:        MSExchange ADAccess
Datum:         20.06.2011 23:34:34
Ereignis-ID:   2080
Aufgabenkategorie:Topologie
Ebene:         Informationen
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      EX01.co-lo-trans.de
Beschreibung:
Prozess MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=4832). Der Exchange Active Directory-Anbieter hat folgende Server mit folgenden Eigenschaften gefunden: 
(Servername | Rollen | Aktiviert | Erreichbarkeit | Synchronisiert | GK-fähig | PDC | SACL-Recht | Benötigte Daten | Netlogon | Betriebssystemversion) 
Innerhalb des Standorts:
DC01.xxx.xxx	CDG 1 7 7 1 0 1 1 7 1
Außerhalb des Standorts:
 
    • Wir sehen also nun eine 1 mehr (CDG 1 7 7 1 0 1 1 7 1 statt CDG 1 7 7 1 0 0 1 7 1)
  • Hurra!
    • alle anderen Exchange Dienste wieder starten - die Dienste sollten nun zügig starten
    • den Exchange Dienst "Geschützter Microsoft Exchange-Diensthost" auch starten (ist auch auf die Schnauze gefallen)
    • Einmal alles Testen
    • Die Dienste wieder umstellen auf den Automatischen Start! bzw. von deaktiviert wieder auf Manuell

Woran es lag...

In meinem Beispielfall hier kamen folgende Fehler zusammen:

  • Nach der Deinstallation des alten Exchange passten die Mitgliedschaften der Exchange Server (bzw. des verbliebenen Exchange Servers) in den Exchange Gruppen nicht mehr
  • Nach der Deinstallation des Domänencontrollers hatte er keinen Domänecontroller mehr mit er richtig reden konnte
  • Das "CDG 1 7 7 1 0 1 1 7 1" sagt uns das er die Domänencontroller nicht richtig erkennen kann bzw. das SACL-Recht nicht hat was er zum Auslesen der Informationen braucht
  • Das Problem haben wir mit der Überprüfung der Gruppenmitgliedschaften und den Einstellungen in der Gruppenrichtlinie behoben
  • Das IPv6 Protokoll war deaktiviert - tödlich, Exchange 2010 (und Exchange 2007?) brauchen das zum starten der Dienste
  • Je nachdem wieviel vorher schon gespiellt wurde sollte es aber lokal deaktiviert werden über den Registry-Schlüssel (NICHT in den Netzwerkkarteneinstellungen)
  • Der Exchange Server bzw. die Dienste konnte bestimmte Webseiten im Internet nicht abrufen (kein Internetzugang)




Kommentare

Kommentare


80.128.171.162

1835 Tage zuvor
Punkte 0+-

Danke! Hat mir sehr geholfen!

Gruesse

178.15.24.218

1802 Tage zuvor
Punkte 0+-
super Beitrag ! vielen dank für die ausführliche Aufarbeitung deines Problems konnte damit einige Mysterien aufklären.

84.160.21.3

1650 Tage zuvor
Punkte 0+-
Der Hinweis auf IPv6 hat mir geholfen, vielen Dank

carstenhirsch@outlook.com

409 Tage zuvor
Punkte 0+-
...bei mir wars auch so: gutgemeinte abschaltung von IP6 - was intern ja Sinn macht - extern. Wieder ON und gut wars.

134.3.131.32

1547 Tage zuvor
Punkte 0+-
Super Sache, hat mir sehr geholfen. Vielen Dank

194.208.48.34

1541 Tage zuvor
Punkte 0+-
DANKE !

84.187.193.157

1436 Tage zuvor
Punkte 0+-

Warum müssen wir nur alles diese schmerzlichen erfahrungen machen ???

Lach....


Guter Beitrag !

188.192.107.141

1332 Tage zuvor
Punkte 0+-

Ich schick für Dich ein fettes Stoßgebet in den Himmel. Ohne Deine Ausführlichen Hinweise hätte ich ganz schön alt gesehen.

Herzlichen Dank!!!

Marcel

963 Tage zuvor
Punkte 0+-
Vielen Dank für deine Ausführungen, das hat mich gerettet!

Marcus

863 Tage zuvor
Punkte 0+-

Rettung morgens um 2 Uhr.

Danke für diese ausführliche Anleitung

BLinz

861 Tage zuvor
Punkte 0+-

Bin neulich selbst wieder reingefallen ... und beim googeln nach dem Fehler kam ich auf meine eigene Seite :-)

Hatte in einem Akt von Wahnsinn das IPv6 Protokoll deaktiviert.

Bernhard

Rainer

752 Tage zuvor
Punkte 0+-

Anleitung trifft genau das Problem.

die Aktualisierung der Gruppenrichtlinien sollte auch dann erfolgen, wenn im Moment keine Änderungen gemacht wurden

Super Hinweis

726 Tage zuvor
Punkte 0+-

...der genau das Problem trifft.

Vielen lieeeeeeeben Dank

Haydar

Torsten

408 Tage zuvor
Punkte 0+-

Danke. Nach 3 Tagen suchen und verzweifeln so eine „einfache“ Lösung zu finden hätte ich nicht mehr gedacht war kurz vor der Neu Installation.

Weiter so nochmals DANKE

BLinz

408 Tage zuvor
Punkte 0+-
Dabei habe ich doch extra mir die Mühe gemacht und alle Eventlog-meldungen mit aufzuführen ... danach googelt man doch als erstes :-) Freut mich aber das ich helfen konnte.

TomBerg

318 Tage zuvor
Punkte 0+-

Ist zwar schon ein alter thread, ABER WIE HILFREICH!!

Und dann noch diese Schreibe, so wohltuend treffend verglichen mit dem Microsoft- "Geschraube"

Danke ;-)
Kommentar hinzufügen:
Gebe hier einen Kommentar ein. Du kannst einen beliebigen Namen oder eine Email-Adresse als Namen angeben.

Wenn du dich einloggst wird automatisch dein Benutzername genommen.
Du kannst KEINE Links hier posten - das wurde wegen anhaltender Werbung deaktiviert. Sobald ein '''http://''' im Text vorkommt wird der Kommentar verworfen Alle anderen Steuerzeichen oder Funktionen wie < br > werden ausgefiltert - zum Posten von Quelltexten ist diese Funktion hier nicht geeignet.

Falls du dringendere Fragen hast kannst du auch das Support-System von znil.net nutzen unter support.znil.net