Aktionen

Citrix:Explorer.exe als published application unter Xenapp 6 wird nicht gestartet

Aus znilwiki

Wenn man den Explorer als einzelne Anwendung unter Citrix veröffentlichen will, konnte man bisher immer auf die normale Explorer.exe zurückgreifen oder einen Workaround von Citrix verwenden, der den Internet Explorer mit einem Laufwerksbuchstaben aufgerufen hat und somit dafür sorgte, dass der Explorer startet.

Dieser Workaround scheint unter Server 2008R2 und XENAPP 6 nicht mehr durchgängig zu funktionieren. Hier tritt häufig das Phänomen auf, dass der Explorer kurz startet und dann sofort wieder verschwindet.

Wenn man den Internet Explorer Workaround verwendet, startet die Applikation mit einem Desktop im Hintergrund -> auch keine Lösung.

Nachdem ein anderer gepeinigter Admin einen Support Case bei Citrix eröffnet hat, gibt es nun eine Lösung:

Einfach im Schlüssel

HKEY_LOCAL_MACHINE\SYSTEM\Control\CurrentControlSet\Control\Citrix\Wfshell\TWI

einen neuen Wert eintragen

LogoffCheckerStartupDelayInSeconds (DWORD32) = 100 (dezimaler Wert)

Dieser Wert zieht sofort für jede neue Usersession. Es ist also KEIN Neustart notwendig!

Eine weitere Variante ist, ein ADM File für eine Citrix Policy dafür zu schreiben:

CLASS MACHINE 
CATEGORY "Citrix Settings" 
KEYNAME "SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI" 
POLICY "Startup Delay" 
PART "Set delay" NUMERIC REQUIRED SPIN 100 
VALUENAME "LogoffCheckerStartupDelayInSeconds" 
END PART 
END POLICY 
END CATEGORY


Anonymer Benutzer #1

79 Monaten zuvor
Punktzahl 0++
Funktioniert prima, aber im Citrix AppCenter wird der Explorer nicht als geöffnete Application angezeigt.

Anonymer Benutzer #2

73 Monaten zuvor
Punktzahl 0++
Der Registry Eintrag funktioniert, danke für die Info!
Kommentar hinzufügen
znilwiki freut sich über alle Kommentare. Sofern du nicht anonym bleiben möchtest, trage deinen Namen oder deine Email-Adresse ein oder melde dich an. Du kannst das Feld auch einfach leer lassen.